Multi Column Page Mpdf Yii2

Berikut contoh view untuk mpdf multi column:

<div class="panel panel-default panel-body" style="font-family: times new roman; border: none; margin:40px; margin-top:0px;" >
 <div class="col-sm-12">
 <columns column-count="2" column-gap="5" width="100%"/>
 <div class="col-sm-6">
 <table width="100%" style="text-align: center; font-size: 11px; font-family: times new roman;">
 <?php foreach($TableLaporan as $data) : ?>
 <tr>
 <td>
 <?php echo $data['Title']; ?>
 </td>
 </tr>
 <?php endforeach ?>
 </table>
 </div>
 <columnbreak />
 </div>
</div>

Saved Tutorial Link

Ini catatan pribadi untuk menyimpan link dari website blog atau video orang lain yang menurut saya penting dan akan saya buka untuk referensi belajar.

All About Yii2 + MongoDB

Link Youtube:

  1. Yii2 MongoDB – Video 1: Setup Yii2 with MongoDB and Create user function : https://www.youtube.com/watch?v=1msu95ZkRe8
  2. Yii2 MongoDB – Video 2: Generate Mongo Model, Controller, CRUD with Gii Tool : https://www.youtube.com/watch?v=1urmws7hz5Q
  3. MongoDB Tutorial for Beginners – 14 – Backup and Restore : https://www.youtube.com/watch?v=CHNB38MAvKY
  4. Yii2 MongoDB – Video 3: Generate i18n for multi language : https://www.youtube.com/watch?v=pPuz_mrWLME

Link Blog:

  1. i18n with Yii 2 Advanced Template : https://thecodeninja.net/2014/12/i18n-with-yii-2-advanced-template/

Setting Virtual Host Server Ubuntu 14.04 LTS

  1. How To Set Up Apache Virtual Hosts on Ubuntu 14.04 LTS : https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-14-04-lts
    (
    Tested and works)

 

Can’t install mongodb apache on ubuntu 14.04

Oke kali ini mau share pengalaman barusan ketika mau mengaplikasikan aplikasi saya yang menggunakan Yii2 + mongodb. Ketika saya mau install Yii2 Mongodb lewat composer, saya mendapatkan pesan error bahwa extension PHP mongodb harus terinstall di aplikasi server saya. Maka dari itu saya melakukan Setup MongoDB, PHP5 & Apache2 on Ubuntu, untuk caranya silahkan googling dengan keyword “setup mongodb  PHP5  apache2”. Untuk langkah-langkahnya tidak saya jelaskan disini karena saya akan membahas tentang error yang saya alami.

Saya mendapatkan Error ketika melakukan instalasi mongo via pecl dengan ketik perintah

sudo pecl install mongo

saya mendapatkan pesan error sebagai berikut :

could not extract the package.xml file from "/build/php5-E9E_1A/php5-5.5.9+dfsg/pear-build-download/mongo-1.6.14.tgz"
Download of "pecl/mongo" succeeded, but it is not a valid package archive
Error: cannot download "pecl/mongo"
Download failed
install failed

Setelang saya googling, ternyata permasalahan tersebut banyak yang mengalaminya ketika mereka menggunakan tipe server yang sama, yaitu menggunakan Ubuntu Server 14.04 32bit.

Akhirnya saya menemukan jawaban yang saya cari di forum tersebut. Caranya dengan mengganti command “sudo pecl install mongo” dengan

sudo pecl install --nocompress mongo

Setelah saya menjalankan command tersebut, Poof mongo extension berhasil terinstall, dan saya pun bisa langsung install plugin mongodb di aplikasi Yii2 saya menggunakan composer